1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Engine Cuts Out

Discussion in 'Vectra C Chat' started by Antibabes, Jun 22, 2017.

Thread Status:
Not open for further replies.
  1. Antibabes

    Antibabes Member

    Joined:
    Mar 3, 2013
    Messages:
    124
    Likes Received:
    10
    Location:
    York
    Drives:
    Vectra C 2.2 SRI
    Hi, went to start the vec today and at first it wouldn't start, then when it did start it would cut out after a few seconds, when it would drive it only managed a few yards.

    So iv plugged it in and got 2 errors.

    P0190 - Fuel Rail Pressure Sensor Circuit Malfunction
    P1113 - No description available for this trouble code

    My vec is a 54 2.2 direct, replaced the fuel pressure regulator and fuel pump a couple years ago.

    What is also strange is the traction control light has lit up...

    Thanks in advance for any help
     
  2. tubbz2015

    tubbz2015 Well-Known Member

    Joined:
    Apr 1, 2015
    Messages:
    1,307
    Likes Received:
    611
    Location:
    Telford West Midlands
    Drives:
    vectra b 3.2 gsi
    Sound like you need a new fuel pressure regulator again mate and i think the p113 code refers to the swirl flaps i could be wrong though
     
  3. stewartjay

    stewartjay Well-Known Member

    Joined:
    Mar 12, 2014
    Messages:
    1,083
    Likes Received:
    369
    Location:
    glasgow
    Drives:
    2001 Vectra B Estate
    Check any wiring as well mate incase its brittle or as danny says new regulator
     
    tubbz2015 likes this.
  4. garybaldi69

    garybaldi69 Administrator
    Staff Member Administrator Elite Member

    Joined:
    Jan 1, 2014
    Messages:
    948
    Likes Received:
    597
    Location:
    Wallsend, Tyne and Wear
    Drives:
    Vec C CDTI 1?? Bus!
    I think the high pressure fuel pump on these engines are prone for going. Worth checking out I think
     
  5. Antibabes

    Antibabes Member

    Joined:
    Mar 3, 2013
    Messages:
    124
    Likes Received:
    10
    Location:
    York
    Drives:
    Vectra C 2.2 SRI
    Just had a quick mess around under the bonnet. It ran for about 5 mins even managed to rev the engine a little. Manually moved the swirl flaps and it died.
    Fuel pump is less than 2 year old and cars only done about 2000 miles in 2 years. Regulator is a little older as I replaced that maybe 3+ years ago.

    I'm wondering could it be the fuel pressure sensor itself that's at fault? Just with the fault code mentioning the sensor circuit...

    Also I noticed after it stalled the fuse box made a high pitched buzzing noise, never heard it before wondering if it normally does that when the engine hasn't started?
     
Thread Status:
Not open for further replies.